Stipend Delays
Incident Report for Second Life
Resolved
All stipends should now be delivered.
Posted Jan 14, 2025 - 12:32 PST
Investigating
We are aware that some users are experiencing delays in receiving their weekly stipends, Our engineers are investigating now, and stipends will be paid out as soon as the issue is resolved. We will update this blog when delays have been cleared.
Posted Jan 14, 2025 - 06:36 PST