Unscheduled Marketplace Maintenance

Incident Report for Second Life

Resolved

The Marketplace maintenance has been resolved.
Posted Mar 28, 2024 - 07:21 PDT

Investigating

We are aware that some Residents may be having trouble creating new Marketplace listings or editing existing Listings. We apologize for any inconvenience and we are actively investigating these issues. Please follow this blog for updates.
Posted Mar 27, 2024 - 09:58 PDT
This incident affected: Websites (marketplace.secondlife.com).