Secondlife.com Outage
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 23, 2023 - 06:34 PDT
Investigating
Secondlife.com is currently experiencing some difficulties, which may cause it to run slowly or error. While we work to bring this service back to full functionality, Secondlife.com may be inaccessible.

We will update this blog when this web service has been restored.
Posted May 22, 2023 - 13:04 PDT
This incident affected: Websites (secondlife.com).