Unscheduled Maintenance on Billing
Incident Report for Second Life
Resolved
The issue has been resolved.
Posted Oct 25, 2019 - 10:17 PDT
Investigating
We are currently investigating an issue causing residents from Japan to experience issues transacting while using a Mastercard as their payment method. Other payment methods are working as normal. Please contact support with any additional questions or concerns.
Posted Sep 17, 2019 - 07:42 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).