Second Life Sound Issue
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 15:45 PST
Investigating
We are aware that some residents are currently experiencing sounds repeating while on RC regions, and are investigating.

Please monitor this blog for additional updates
Posted Dec 14, 2022 - 12:48 PST
This incident affected: Second Life Regions (Second Life Release Candidate Regions).