Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This unscheduled maintenance has been resolved. Thank you for your patience!
Posted 12 days ago. Dec 01, 2018 - 12:24 PST
Investigating
We are currently undergoing unscheduled maintenance to our billing system. Residents may experience issues making in-world, Marketplace, and/or USD transactions during this time. Please monitor this blog for further updates. We thank you for your patience during this time.
Posted 12 days ago. Dec 01, 2018 - 11:31 PST
This incident affected: Websites (secondlife.com, marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases).