Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 19, 2023 - 07:37 PDT
Investigating
We are currently undergoing unscheduled maintenance on our billing systems. While this maintenance is in progress, Residents may be unable to use the cashier or to make purchases using credit cards. Please watch this blog for updates.
Posted May 19, 2023 - 06:59 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).