Billing Maintenance
Incident Report for Second Life
Resolved
The billing maintenance is complete.
Posted 5 months ago. Apr 03, 2019 - 13:57 PDT
Investigating
We are currently performing maintenance on our billing systems. While this maintenance is in progress, residents may be unable to start or continue purchases. Please watch this blog for updates.
Posted 5 months ago. Apr 03, 2019 - 13:37 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases).