Billing Maintenance
Scheduled for Dec 12, 08:30 - 09:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 11, 2024 - 14:14 PST
Scheduled
We will be performing maintenance on our billing systems on Thursday, December 12 at 8:30 AM PST. While this maintenance is in progress, Residents may be unable to use the cashier or to make purchases. Please watch this blog for updates.
Posted Dec 11, 2024 - 14:11 PST
This scheduled maintenance affects: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).