Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 3 months ago. May 06, 2019 - 13:31 PDT
Update
The unscheduled maintenance has been resolved.
Posted 3 months ago. May 06, 2019 - 13:29 PDT
Investigating
Second Life is currently undergoing unscheduled maintenance. This may result in troubles logging on or using inworld services. Please watch this blog for further information
Posted 3 months ago. May 06, 2019 - 08:22 PDT
This incident affected: Second Life Services (Logins).