Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 3 months ago. Jan 03, 2019 - 07:39 PST
Investigating
We are undergoing unscheduled maintenance to our billing system at this time. Residents may not be able to view their transaction histories during this maintenance. Please monitor this blog for further updates. We thank you for your patience.
Posted 3 months ago. Jan 02, 2019 - 08:22 PST