Support Portal Login Outage
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jan 10, 2023 - 08:31 PST
Identified
We have received reports that residents may be having trouble accessing or submitting support tickets at this time. We will update this blog when this web service has been restored.
Posted Jan 10, 2023 - 06:59 PST
This incident affected: External Support (Case Support).