Unscheduled Dashboard Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 18, 2024 - 15:20 PST
Investigating
Secondlife.com and searches are currently experiencing difficulties, which may cause them to run slowly or produce an error. We are working to bring these service back to full functionality. Please follow this blog for updates.
Posted Feb 18, 2024 - 06:41 PST
This incident affected: Websites (secondlife.com, my.secondlife.com).