Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 13:56 PDT
Update
Please note that this maintenance may affect residents' ability to access Skill Gaming Regions. We apologize for any inconvenience.

Please follow this blog for additional updates.
Posted Jun 10, 2022 - 13:41 PDT
Investigating
We are currently performing unscheduled maintenance on our billing systems. During this time, some Second Life billing services and transactions may be unavailable. Please refrain from transacting in-world, on the Marketplace, or on the Lindex during this time.

We apologize for any inconvenience. Please monitor this blog for additional updates.
Posted Jun 10, 2022 - 13:26 PDT
This incident affected: Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits), Websites (marketplace.secondlife.com), and Inworld Services (L$ Transactions).