Canny/Feedback Site Outage

Incident Report for Second Life

Resolved

This issue has been resolved.
Posted Feb 28, 2024 - 15:50 PST

Investigating

Our feedback site, Canny (https://feedback.secondlife.com/), is encountering an outage. Residents may experience difficulty accessing Canny at this time.

We are reaching out to Canny in efforts to resolve this, but in the meantime, please watch this blog for updates.
Posted Feb 28, 2024 - 12:05 PST