Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled billing maintenance. Thank you again for your patience during this time.
Posted 5 months ago. Nov 01, 2018 - 17:31 PDT
Investigating
We are currently conducting an unscheduled Billing maintenance. You may experience issues making in-world or USD transactions during this time. Please monitor this blog for further updates. We thank you for your patience during this time.
Posted 5 months ago. Nov 01, 2018 - 17:09 PDT