Phone and Live Chat Support Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 06:56 PDT

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 06:55 PDT

Investigating

Phone and Live Chat support will be unavailable on Tuesday, April 1st from 6:45 AM PDT to 7:15 AM PDT. Ticket submissions and Live chat will still be available at this time.
Posted Apr 01, 2025 - 06:46 PDT
This incident affected: External Support (Phone Support).