Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted Apr 14, 2020 - 09:06 PDT
Investigating
We are aware that Residents are receiving errors while trying to access the Second Life Marketplace. Our operations team is investigating.
Posted Apr 14, 2020 - 07:25 PDT
This incident affected: Websites (marketplace.secondlife.com).