Unscheduled Website Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 2 months ago. Jun 05, 2018 - 14:34 PDT
Investigating
We are currently performing unscheduled maintenance. During this maintenance, some users may experience issues when logging into Second Life websites. Live chat and ticket support may be temporarily unavailable. Live phone support is available.
Please check this blog for updates.
Posted 2 months ago. Jun 05, 2018 - 14:05 PDT