Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 13:05 PDT
Investigating
We are currently performing maintenance on our billing systems. While this maintenance is in progress, Residents may be unable to use the cashier or to make purchases. Please watch this blog for updates.
Posted Mar 16, 2020 - 09:46 PDT
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).