Bake Services Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 14:32 PDT
Investigating
We are currently working on bake services, and avatars may experience trouble changing outfits while this maintenance is in progress. Please check this blog for further updates.
Posted Aug 18, 2020 - 13:40 PDT
This incident affected: Inworld Services (Rezzing, Inventory).