Live Chat Support Maintenance
Incident Report for Second Life
Resolved
The scheduled maintenance has been completed.
Posted Aug 27, 2023 - 11:11 PDT
Investigating
Chat support will be unavailable Sunday, August 27th from 10 a.m. PST - 11 a.m. PST. Ticket submissions will still be available at this time.
Posted Aug 27, 2023 - 09:50 PDT
This incident affected: External Support (Chat Support).