Unscheduled Live Chat Maintenance
Incident Report for Second Life
Resolved
Maintenance has been completed.
Posted May 17, 2021 - 13:33 PDT
Investigating
We are currently investigating Live Chat support issues. During this time, Live Chat may be slow to respond or experience other issues. Please monitor this blog for updates.
Posted May 17, 2021 - 09:55 PDT
This incident affected: External Support (Chat Support).