Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 15:00 PDT
Scheduled
We will be performing scheduled maintenance on 1 July 2025 starting at 3:00 PDT. During this time, some users may be logged out, and logins will fail. Additionally, some users that remain logged may experience voice, chat and teleport failures.
Please monitor this blog for additional updates.
Posted Jul 01, 2025 - 06:57 PDT
This scheduled maintenance affects: Second Life Services (Logins, LindeX Purchases, Marketplace Purchases, Process Credits), Second Life Regions (Second Life Main Channel Regions, Second Life Release Candidate Regions), Websites (marketplace.secondlife.com, community.secondlife.com, wiki.secondlife.com, my.secondlife.com, feedback.secondlife.com, support.secondlife.com, search.secondlife.com, places.secondlife.com, land.secondlife.com), and Inworld Services (L$ Transactions, Rezzing, Profiles, Teleports, Group Voice Chat).