Some Weekly Stipends Delayed
Incident Report for Second Life
Resolved
Thank you for your patience! Stipends have been distributed! Please check your Linden$ balance - if you have still not received your stipend, please feel free to reach out through Live Chat, or submit a Support Case before 3:00 SLT.
Posted 13 days ago. Nov 07, 2017 - 11:00 PST
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We apologize for any inconvenience this may cause you, and we are in the process of getting them out. We will update this blog when that has been completed. Thank you for your patience!
Posted 13 days ago. Nov 07, 2017 - 05:35 PST
This incident affected: External Support (Chat Support) and Inworld Services (L$ Transactions).