Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 13, 2017 - 17:38 PDT
Update
We're continuing to work on the login service.
Posted 2 months ago. Jun 13, 2017 - 17:19 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jun 13, 2017 - 15:58 PDT
This incident affected: Second Life Services (Logins).