Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
Thank you so much for your patience! Billing Maintenance is now complete!
Posted 25 days ago. Nov 18, 2017 - 07:20 PST
Investigating
We are currently performing unscheduled maintenance. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. Credit card processing may be affected during this time as well. Please check this blog for updates.
Posted 25 days ago. Nov 18, 2017 - 06:07 PST
This incident affected: Inworld Services (L$ Transactions) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).