Payment support for Residents in Turkey
Incident Report for Second Life
Resolved
This issue has been resolved. Thank you for your patience while we worked to find a solution for our Turkish residents.
Posted Apr 06, 2021 - 12:02 PDT
Monitoring
We're happy to announce that we've reached an agreement with Rapyd Financial Network (https://www.rapyd.net/) for payout support for our Residents in Turkey. In order to request a payout, please submit a "Wire Request" under the issue type "Tilia Account" from our support portal and we will follow up with necessary next steps for your case. You may find that we need a few extra days to process your payments as we get this new flow ironed out.
Posted Jan 22, 2021 - 12:31 PST
Identified
We’ve identified a solution for payments to our residents in Turkey, and are working on getting that in place. We will be able to share more details about it soon, and look forward to enabling our community to continue creating amazing content in SL.
Posted Jan 13, 2021 - 14:28 PST
Investigating
We’re aware of the issues with payment provider support for our Residents in Turkey. We’re looking at options to continue supporting them.
Posted Nov 11, 2020 - 11:04 PST