Limited availability of new Regions
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 13:27 PST
Update
While the Land Store maintenance continues, it's still possible to get new regions via a support ticket under Land & Region > Order Private Region. We're working on getting things back to normal, and apologize for the delays.
Posted Feb 16, 2021 - 14:08 PST
Identified
The Land Store will be undergoing unscheduled maintenance. We are sorry for the inconvenience!
Although the land store is unavailable, new regions are still available for purchase via a support ticket, filed under Land & Region > Order Private Region.
Please see https://community.secondlife.com/blogs/entry/4497-limited-availability-of-new-second-life-regions/ for more information and other options for finding land in SL.
It is still possible to manage your current land holdings via land.secondlife.com.
Posted Dec 22, 2020 - 10:14 PST
This incident affected: Websites (land.secondlife.com).