Tilia Terms of Service (ToS) Update and Known Login Issue
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Aug 19, 2024 - 10:05 PDT
Update
We are aware of a login issue pertaining to the Tilia ToS update. For residents with multi-factor authentication enabled you will need to log into your Second Life Tilia dashboard and accept the Terms of Service. Please follow this blog for updates.
Posted Aug 05, 2024 - 12:17 PDT
Identified
There will be an update to Tilia's Terms of Service (ToS) today, Tuesday July 30.

Residents may need to accept the new Tilia Terms of Service before accessing Tilia services.

Please monitor this blog for updates.
Posted Jul 30, 2024 - 10:48 PDT