Unscheduled Website Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 13 days ago. Jul 03, 2018 - 15:13 PDT
Investigating
We are currently undergoing unscheduled maintenance on secondlife.com that may be preventing logins to the website for some or all users. Logins for Second Life via the viewer are unaffected.
Posted 13 days ago. Jul 03, 2018 - 14:55 PDT
This incident affected: Websites (secondlife.com).