Unscheduled Name Change Maintenance

Incident Report for Second Life

Resolved

Unscheduled maintenance on the Second Life Name Change service has been completed. Residents should now be able to complete name changes as expected.

We apologize for the inconvenience and appreciate your understanding.
Posted Jun 18, 2026 - 10:03 PDT

Identified

We are currently performing unscheduled maintenance on the Second Life Name Change services.

During this maintenance, some Residents may be unable to complete a name change or may receive an error when attempting to use the service. We estimate this maintenance will last approximately 45-75 minutes. We apologize for the inconvenience and appreciate your patience while we work towards a resolution.

For any issues after maintenance has ended, please submit a support ticket at:
https://lindenlab.freshdesk.com/support/tickets/new
Posted Jun 18, 2026 - 09:35 PDT
This incident affected: Websites (secondlife.com).