Maintenance to SecondLife.com Login Portal

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Feb 14, 2024 - 10:12 PST

Update

We are continuing to investigate this issue.
Posted Feb 08, 2024 - 06:56 PST

Investigating

Investigating - Secondlife.com and searches are currently experiencing difficulties, which may cause them to run slowly or produce an error. We are working to bring these service back to full functionality. Please follow this blog for updates.
Posted Feb 08, 2024 - 06:32 PST
This incident affected: Websites (secondlife.com, my.secondlife.com, search.secondlife.com).