Concierge Phone and Concierge & Premium Chat Support Unavailable
Incident Report for Second Life
Resolved
The scheduled maintenance has been completed.
Posted 9 months ago. Jan 19, 2018 - 13:02 PST
Investigating
Concierge phone, Premium chat support and Billing phone will be unavailable from 12:00 PM to 1:00 PM PST, today January 19th, 2017. Case submissions are still available
Posted 9 months ago. Jan 19, 2018 - 12:02 PST
This incident affected: External Support (Chat Support, Phone Support).