Second Life - Login Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 12 days ago. Nov 05, 2018 - 09:20 PST
Update
Residents may experience intermittent difficulty logging into Second Life as we continue to monitor and investigate this situation. We deeply apologize for any inconvenience this may cause and we hope to have this situation resolved as quickly as possible.
Posted 15 days ago. Nov 02, 2018 - 14:58 PDT
Investigating
We are currently experiencing issues with log ins that are currently being investigated. Residents may experience log outs at this time. Please continue to check this blog for updates.
Posted 15 days ago. Nov 02, 2018 - 09:34 PDT
This incident affected: Second Life Services (Logins).