Live Chat and Ticket Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 06, 2022 - 08:16 PDT
Investigating
We are currently performing maintenance on our support systems. At this time, live chat and ticket submissions may be unavailable. We apologize for any inconvenience.

Please follow this blog for updates.
Posted May 06, 2022 - 07:28 PDT
This incident affected: External Support (Chat Support) and Websites (support.secondlife.com).