Second Life Marketplace Issues

Incident Report for Second Life

Resolved

The Marketplace login issue is resolved. If residents are experiencing any further issues accessing the Marketplace please contact Support.
Posted Oct 23, 2020 - 13:31 PDT

Investigating

We are aware that Residents are experiencing issues logging in, and seeing some delays, while trying to access the Second Life Marketplace. Our operations team is investigating.
Posted Oct 22, 2020 - 07:49 PDT
This incident affected: Websites (marketplace.secondlife.com).