Unscheduled Live Chat Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved and Live Chat is now accessible.
Posted Jun 04, 2020 - 07:18 PDT
Investigating
We are aware of an issue with live chat support and we are currently investigating. Ticket submissions are still available during this time if you are experiencing issues contacting support via live chat.
Posted Jun 04, 2020 - 06:41 PDT
This incident affected: External Support (Chat Support).