Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The billing maintenance has been resolved.
Posted May 29, 2020 - 13:48 PDT
Investigating
We are currently seeing an increased load in our billing systems, and payment attempts will not complete for residents for a short period. Please watch this blog for updates.
Posted May 29, 2020 - 13:11 PDT