Login Issues
Incident Report for Second Life
Resolved
This login issue has been resolved. Please contact support if you are still experiencing a problem logging in.
Posted 4 days ago. Oct 11, 2019 - 06:12 PDT
Investigating
We are currently aware of login issues affecting some Time Warner and Spectrum customers in the eastern United States (particularly in Ohio and Kentucky). If you are affected by these issues, please contact your Internet Service Provider for assistance.
Posted 6 days ago. Oct 09, 2019 - 13:02 PDT
This incident affected: Second Life Services (Logins).