Unscheduled Support Website Maintenance
Incident Report for Second Life
Resolved
The issue has been resolved. Please contact Support if you have experienced any issues with submitting support tickets.
Posted 9 months ago. Mar 21, 2018 - 12:16 PDT
Investigating
We are aware that there may be issues with submitted support tickets at this time. We are actively investigating the issue, and will provide updates via this blog.
Posted 9 months ago. Mar 21, 2018 - 09:29 PDT
This incident affected: Websites (support.secondlife.com).