Premium Stipend Issue
Incident Report for Second Life
Resolved
Thank you for your patience - stipend deliveries have been resolved! If you find that you have an issue that remains unresolved, please contact us directly at https://support.secondlife.com/
Posted 28 days ago. Jun 27, 2017 - 10:52 PDT
Update
Stipend deliveries are now underway. We thank you for your continued patience. Please check back here for further updates.
Posted 28 days ago. Jun 27, 2017 - 09:26 PDT
Update
We are still investigating the failure to deliver stipends. We appreciate your continued patience. Please check back here for further updates.
Posted 28 days ago. Jun 27, 2017 - 09:13 PDT
Investigating
We have been made aware that some residents have not received their Weekly Premium Stipend. We are investigating the cause of this issue. Please keep an eye on this blog post for updates as they become available.
Posted 28 days ago. Jun 27, 2017 - 07:07 PDT
This incident affected: Second Life Regions (Second Life Main Channel Regions, Second Life RC LeTigre Regions, Second Life RC BlueSteel Regions, Second Life RC Magnum Regions, Second Life RC Snack Regions, Second Life RC Cake Regions) and Inworld Services (L$ Transactions).