Inventory Maintenance
Incident Report for Second Life
Resolved
The inventory maintenance has been completed
Posted May 05, 2022 - 14:21 PDT
Investigating
Inventory is undergoing maintenance at this time. Residents may experience downtime with their inventory during this maintenance.
Posted May 05, 2022 - 13:57 PDT
This incident affected: Second Life Services (Marketplace Purchases) and Inworld Services (Inventory).