Unplanned Voice Service Maintenance

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Nov 21, 2022 - 11:52 PST

Investigating

Second Life’s voice services are currently experiencing issues. During this time voice service may be intermittent or unavailable entirely. Please watch this page for updates!
Posted Nov 21, 2022 - 11:36 PST
This incident affected: Inworld Services (Voice Chat, Group Voice Chat).