Second Life Website Unscheduled Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 28, 2017 - 10:38 PDT
Update
Our website maintenance is complete.
Posted 5 months ago. Jul 28, 2017 - 10:38 PDT
Investigating
We are investigating an issue with our Second Life websites. Residents may not be able to login at this time. Chat and case submission may also be unavailable. Please keep an eye on this blog for updates.
Posted 5 months ago. Jul 28, 2017 - 09:01 PDT
This incident affected: External Support (Chat Support, Case Support) and Websites (secondlife.com, support.secondlife.com, search.secondlife.com, places.secondlife.com).