Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled billing maintenance has been completed. We thank you for your patience.
Posted 9 months ago. Mar 21, 2018 - 16:16 PDT
Investigating
We are currently performing unscheduled maintenance. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. International Payments and adding Payment Methods may be affected.

Please check this blog for updates.
Posted 9 months ago. Mar 21, 2018 - 15:22 PDT