Concierge and Premium Plus Phone Support Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 11, 2023 - 09:08 PST
Investigating
Concierge and Premium Plus Phone support will be unavailable on Sunday, December 10, 2023. Ticket submissions and Live chat will still be available at this time. Phone support will resume on Monday, December 11, 2023.
Posted Dec 10, 2023 - 06:13 PST
This incident affected: External Support (Phone Support).