Marketplace Maintenance
Incident Report for Second Life
Resolved
The maintenance has been completed.
Posted Oct 26, 2022 - 13:45 PDT
Investigating
The marketplace is not currently accessible while maintenance is ongoing.

Please monitor this blog for updates.
Posted Oct 26, 2022 - 12:31 PDT
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).