Unscheduled Maintenance to my.secondlife.com
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 12:51 PDT
Investigating
My.secondlife.com is undergoing maintenance while we are investigating reports of profile posts and snapshots not properly deleting when requested. Residents visiting my.secondlife.com may see that the website is inaccessible and report as down for maintenance. Please follow this blog for updates.
Posted Oct 07, 2022 - 11:01 PDT
This incident affected: Websites (my.secondlife.com).