Unscheduled Community Pages Maintenance
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance on the Community Pages.
Posted about 1 month ago. Jun 17, 2019 - 16:55 PDT
Investigating
We are currently investigating an issue with our Community Pages. You may be unable to access the Second Life Forums, Blogs, Answers, and Knowledge Base pages during this time.

We thank you for your patience during this time.
Posted about 1 month ago. Jun 17, 2019 - 15:20 PDT
This incident affected: Websites (community.secondlife.com).